Ford Transit USA Forum banner
41 - 46 of 46 Posts

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #43 ·
I searched my drive, and did not find that file.

Strange. Hard to believe, even. But just maybe they've made a change between whatever version you have and the latest that I received.
 

·
Registered
Joined
·
1 Posts
Thank you both, @orton and @EddieZ . For a short while I was actually considering just leaving this thread a cliff hanger. I'm glad that others have been getting something out of it. I definitely have been.
I am SO very glad you didn't leave this a a cliff hanger! Thank you for such a simple solution. I was poring over the registry looking for clues, I tried PowerISO to make a virtual drive, nothing was working. I joined this forum only so I could say thank you, thank you, thank you!! I don't even own a Transit, haha, I have an Escape and a Fusion.

Gary
 

·
Registered
Joined
·
43 Posts
I thought I'd take a gamble on the only available real service manual I'm aware of for this vehicle. I was excited to receive it, make an image of the CD for use on my laptop with no CD-ROM (don't get ahead of me!), and have at-my-fingertips access to troubleshooting flows, component locations, wiring diagrams, and more.


What did I get? Well, the CD is copy protected for starters. Alcohol 120% (a CD/DVD copying/imaging application) analysis showed that it uses SecuROM 7 "or newer". It claims to be able to circumvent this, but I have been unable to create an image FOR MY OWN GODDDAMN USE because of this crippling and limiting DRM (Digital Rights Management). I was considering purchasing an external optical drive (an additional CAD$50 or so, plus another electronic widget taking up valuable space in my laptop bag. Not desirable in the least bit.


AND THEN... I hadn't actually installed it from the CD yet because I was using someone else's computer with an optical drive in my two evenings worth of attempts to make a disc image. I finally did install it to see what I was missing. I was rewarded with software that looks like it stepped right out of 1995 - er, ok maybe 1998. That's fine, I can live with that if it has the information I want/need. After a few glitches in loading this or that, plus figuring out the idiotic panes and unlabeled arrows/buttons I was able to browse through some troubleshooting flows and follow links from them to other flows... ok, looking good... but when I selected the Wiring Diagrams section I got nothing more than A F***ING BLANK SCREEN. I tried scrolling around using the archaic navigation arrows around the perimeter and received the error shown in the screen shot attached.


Am I impressed? Duh. I'm now wondering if anyone else has gone through anything similar. I'm the sort of person most other people turn to when they have computer problems. When I have computer problems, it's rarely ME. This is on Windows 10, plus I tried using various compatibility settings to no avail.


I'm considering cutting my losses by returning and taking the 25% restocking fee up the .... [ Helm Inc-Your Source for Factory Authorized Service Information ] After, of course, complaining VERY loudly and perhaps even pointing them to this post. I'll bet they won't even cover the return postage.


My original gamble was USD$186. The outlook is bleak.
The best service/tech information for the money is www.ALLDATAdiy.com. The only Problem is for my 350 HD, they are currently only to 2015 models. I gambled and bought one year of access for 19.00 . For most of the information I need for my 2017, there has been no change, so it works. For most of my vehicles, I buy a five year access for about $45.00.

D.L.
John 14:06
 
41 - 46 of 46 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top