Ford Transit USA Forum banner

Espar B4L Heater not starting at Elevation

37448 Views 322 Replies 60 Participants Last post by  brío
So I installed a Espar B4L in my 2020 transit, under the passenger seat and have a problem with the heater starting when I am at elevation.

I live in Boise ID, at around 3k feet elevation, when down here in the valley my heater starts 99% of the time without issues. When I travel to my local ski area around 6800K feet the heater NEVER starts first try and generally will take around 30+ minutes of trying to get the thing started. Once it does starts at elevation, it will run absolutely fine stopping and starting. When I got back down in elevation it also will always start fine, and then back up to elevation I again have the problem.

Ive completely taken apart the entire gas line from the pickup in the tank all the way to the heater, ensuring rise, fittings, etc are perfect... still have the same problem of getting it started at elevation.

Heatso has been sorta OK to work with, but I feel like they dont really know either. They will be sending me a new ECU (when they get them in a couple weeks).

Has anyone had this problem, is there a trick to getting it started I could use until i get the root cause sorted?

Appreciate any pointers!
1 - 1 of 1 Posts

· Registered
Joined
·
1,213 Posts
I have the older Espar B4 model and have used it for over four years in my Transit with no problems. It uses the Ford factory straw and doesn't have an altitude kit (my installer says he checked with Espar and the gasoline models don't need them). I've used the heater at altitude (up to 8400 feet). Also for skiing in the winter.

I've never had a problem starting the heater except when I have let the gas tank run too low. I'm not sure this helps you, but it might add a bit of grist to your diagnostic mill.

Cheers.
 
1 - 1 of 1 Posts
Top