Ford Transit USA Forum banner

41 - 43 of 43 Posts

·
Registered
Joined
·
28 Posts
@Iceguy1 You should be able to tell by physical inspection / have the ebay tell you or take a close up of the connector. Check out my photo of from a few posts back. The front of the clock spring should have all the pins present that are in that photo in a unit with cruise control. It looks like 12 out of 16 pins present I think? At least 5 of them were for cruise if I remember right. For comparison here is a photo of my old clock spring and I imagine yours is the same. Only 6 pins: this is the kind you DON'T want.

If you're having trouble telling them apart I can check the exact pin wiring again. If I remember there is only one other variation for the "level 2" cluster with the lane departure warning system that has one extra pin present. If you got one of those I'm pretty sure it would work too.

tldr if it has 11+ pins on the connector populated it's the one you want.



136252
 

·
Registered
Joined
·
2 Posts
Another success story... got cruise control working on my base model 2018 Transit 250 cargo van. Did everything hayduke said... with some extra air bag safety precautions. I did some clock spring replacement research prior to doing the job. Seems like everybody stresses airbag safety, seems smart so I ...

released the clips on my airbag, leaving it in the steering wheel loose and turned the wheel back to center at 0°

then disconnected the battery and waited 15 minutes for any capacitors to discharge

reconnected the battery to set the new clock spring to the correct position using forscan

disconnected the battery again and waited 15 minutes before re-installing the air bag

Thanks again hayduke and all the others that worked on this. My long drives between service calls are much more enjoyable now
 

·
Registered
Joined
·
28 Posts
Good call on the airbag battery disconnect. I used to do that when working on cars in years past but after watching several Youtube videos and instructional docs where no one mentioned it I figured that must be outdated advice. I was a little bit nervous unplugging and plugging it in. Glad to hear you got it working!
 
41 - 43 of 43 Posts
Top