Ford Transit USA Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Picked up our new XLT Passenger Van with 12" Sync 4 two weeks ago. It was very cold the first few days and didn't realize the climate control only put out super hot air regardless of temperature setting. Took it back to the dealer and they replaced the mixer door (after a week delay because Ford originally sent the wrong part). I picked up the van, selected 68 degrees and.... The air temp was fixed. Unfortunately, 15 minutes later I realized the seat heaters weren't on and tried to push the button, but no joy. The climate section of screen shows you select a change, but then reverts back and nothing happens. Climate control is completely unresponsive.

My wife was not impressed when picking up 10 kids at school and the van fogged up so bad she had to stop twice to clear the windshield. She was already not happy with lack of physical controls and this only confirmed her distrust of the new system.

A little googling showed Ford has a climate control reset procedure by holding power and defrost buttons for 10 seconds, but this doesn't work for the new touch screen! I unhooked the negative battery terminal for 5 mins, but climate control is still unresponsive.

BACK TO THR DEALERSHIP!!
 

· Registered
Joined
·
5,349 Posts
This problem has been discussed a lot lately on the forum, Maybe search out some of those forum threads and see what other people are saying.
Everybody points to the recall first.
 

· Registered
Joined
·
66 Posts
Discussion Starter · #6 ·
Well shoot. Dealer called this morning to report the climate control module is not communicating with the rest of the system and needs replaced. Of course the part is back ordered. Could be weeks. Could be months. They didn't inspire confidence I'd have the van back anytime soon. I'm trying to get a replacement vehicle from them, but haven't heard back from the sales team because the service manager said that's not their job 😵‍💫
 

· Registered
22 Avalanche 148 AWD
Joined
·
458 Posts
Mine must be doing the same. I had the recall done and it is still the same. No way am i leaving my van to wait for a part to come in ever.
 
1 - 8 of 8 Posts
Top