Ford Transit USA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My problem started as an intermittent passenger-side, front only - with fast flashing on side & rear bulbs. I replaced the front bulb & all was good for about three weeks. It started acting up again, then went totally out - front, back, side .. everything out on passenger's side. I replaced headlight assembly after Internet search said the internal "ring" or something could cause this issue.
New part did not resolve it .. it does look much better, though. I'm now wondering what else. I appreciate any input & recommendation.
 

·
Registered
Joined
·
2,010 Posts
ImJG24Fan,

The full size Transits have the same fast flashing problem, sometimes it's the addition of LED bulbs or adding trailer connections. Other times it's unknown. Mine does it occasionally but then resets itself to a regular flash. Don't know if your model has dual filament bulbs for brake/stop or not, but a recent Thread brough up answers that one filament had burned out and was causing problems similar to yours.

Good Luck

If you don't receive an answer here to your question.

Please do not think that my response is an attempt to kick you off of this forum as some mistakenly have alleged. You have posted a question here about a TC in the TC section of this Forum . You have every right to be here and ask questions about your Transit Connect Although some members here believe that giving you information about a Forum made up of members for your specific brand of vehicle, a Transit Connect, rather than a Forum made up of all the categories of Transit available and primarily focused on the full size Transit, is wrong, I don’t.

So if you choose to want to know of a Forum where the membership is focused on one type and category of vehicle only, the Transit Connect, where other TC owners may have the same problems and questions you do, you can click on one or both of the below links. ? BUT ONLY IF YOU WANT TO, please don’t think you are being forced to visit that Forum if you don’t want to. It is your choice.

Good Luck in your search to answer your question.

Semper Fi



 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
1. Thank you for your service.
2. Thanks for the response.

As far as I know, all bulbs are dual-element, except backups & markers. There were no hardware changes or LED bulbs .. it’s all stock.
Much to my surprise, it’s working - mostly. The front-right is still out, the rear & side are back. Must be a flakey connection.
Off to see the dealer, it seems. ?
 
1 - 3 of 3 Posts
Top